咨询热线: 13764045638 7 x 24 在线支持!

Oracle PRM与JVM以及OS

Oracle PRM与JVM以及OS

PRM(ParnassusData Recovery Manager)基于JAVA语言开发,得益于JVM Java虚拟机,PRM可以无需反复编译就在几乎所有支持JAVA的操作平台上运行,包括但不限于:AIX、Solaris、HPUX、Linux和Windows。

 

 

PRM在开发过程中充分考虑了老系统平台,最低可以兼容到JAVA 1.4版本,这意味着那些无法安装新JDK/JRE的老操作系统也可以运行PRM。

 

例如在2003年出品的Red Hat Enterprise Linux AS release 3 (Taroon)上安装了JRE 1.4.2

 

[root@rh3 root]# uname -a

Linux rh3 2.4.21-4.EL #1 Fri Oct 3 18:13:58 EDT 2003 i686 i686 i386 GNU/Linux

[root@rh3 root]# cat /etc/issue

Red Hat Enterprise Linux AS release 3 (Taroon)

Kernel \r on an \m

 

[root@rh3 root]# java -version

java version "1.4.2_19"

Java(TM) 2 Runtime Environment, Standard Edition (build 1.4.2_19-b04)

Java HotSpot(TM) Client VM (build 1.4.2_19-b04, mixed mode)

[root@rh3 root]#

[root@rh3 root]# which java

/usr/bin/java

 

 

10年前出品的RHEL 3同样可以正常运行PRM:

 

java –jar prm.jar

 

 

 

 

 

虽然PRM可以正常在JRE 1.4.2上运行,但为了获得最佳性能和最佳体验,诗檀推荐用户安装JDK 1.6以上版本,建议为JDK 1.7。

 

 

JDK下载

 

 

Linux和Windows上的JDK 1.7较为容易下载,而AIX上的JDK由IBM自行提供,下载较为麻烦。这里提供部分JDK 1.7的下载路径:

 

AIX JAVA SDK 7

http://pan.baidu.com/s/1i3JvAlv

Linux JDK 7 64bit

http://pan.baidu.com/s/1jGl3AT4

Linux JDK 7 32bit

http://pan.baidu.com/s/1mg6ymnQ

Solaris JDK 7 x86-64bit

http://pan.baidu.com/s/1gdzgSvh

Solaris JDK 7 x86-32bit

http://pan.baidu.com/s/1mgjxFlQ

Solaris JDK 7 Sparc

http://pan.baidu.com/s/1pJjX3Ft

 

PRM 启动参数

 

常规情况下PRM使用prm.sh(Unix/Linux) 或 prm.bat(Windows)启动,即:

 

$ ./prm.sh

 

[root@rh3 prm_3002]# cat prm.sh

echo "It's recommended that you can use JDK 1.6 or higher version"

echo "Download latest JDK http://www.oracle.com/technetwork/java/javase/downloads/index.html"

java -Xms1024M -jar prm.jar

 

 

prm.sh在调用prm.jar JAVA程序包时会加上-Xms1024M参数

 

但如果用户所运行的JAVA环境不是JDK 1.6以上版本则可能出现如下的一些问题:

 

  1. prm.sh启动遇到 “Incompatible initial and maximum heap sizes specified”问题

 

[root@rh3 prm_3002]# ./prm.sh

It's recommended that you can use JDK 1.6 or higher version

Download latest JDK http://www.oracle.com/technetwork/java/javase/downloads/index.html

Error occurred during initialization of VM

Incompatible initial and maximum heap sizes specified

 

 

" Incompatible initial and maximum heap sizes specified”该报错是因为当前所运行的JAVA环境不支持-Xms1024M参数,如果不想升级JAVA环境的话,可以执行运行:

 

$ java –jar prm.jar

 

 

 

  1. PRM在redhat自带的gcj java 1.4.2下运行时遇到如下问题:

 

Exception when analysing ASM disk header.

Issue for analysing ASM disk header for: /dev/raw/raw1

Exception when analysing ASM disk header.

Issue for analysing ASM disk header for: /dev/raw/raw2

Exception when analysing ASM disk header.

Issue for analysing ASM disk header for: /dev/raw/raw3

Exception when analysing ASM disk header.

Issue for analysing ASM disk header for: /dev/raw/raw4

Exception when analysing ASM disk header.

Issue for analysing ASM disk header for: /dev/raw/raw5

Exception when analysing ASM disk header.

Issue for analysing ASM disk header for: /dev/raw/raw6

Exception when analysing ASM disk header.

Issue for analysing ASM disk header for: /dev/raw/raw7

~                                                                          

 

gc warning: Repeated allocation of very large block (appr.size 512000):

May lead to memory leak and poor performance.

 

 

 

 

这是因为Redhat自带的GCJ 1.4.2的GC垃圾回收存在问题所导致的,建议使用Oracle JDK 1.6或以上版本, 使用redhat free software foundation 的gcj确实可能发生该问题。

 

 

  1. Prm.bat启动过程中遇到” Error: no `server' JVM at `D:\Program Files (x86)\Java\jre1.5.0_22\bin\server\jvm.dll'.”问题

 

这是因为用户的JAVA运行环境中仅仅安装了JRE,因为jRE在1.5中是没有-server选项的所以出现了如上问题。

 

可以通过升级到JDK 1.6以上版本解决,也可以去掉-server选项来运行,即:

 

java –jar prm.jar